Splitboard.com Forums

The World's first exclusive splitboard discussion forums






It is currently Tue Sep 02, 2014 12:46 am

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: Trouble with Split30s - Nothing seems to fit
PostPosted: Wed Feb 19, 2014 6:20 pm 
Offline

Joined: Mon Jan 13, 2014 12:57 pm
Posts: 3
I've been trying to setup my Split30s on a Venture Zypher and have had nothing but problems.

1) The biggest problem is when I'm putting the binding into ride mode. I have everything lined up, and can put the bindings all the way down on the plates, but the pins that the level activates still barely make it under the tabs by the heel and mid foot. If I close the lever (which is very difficult and requires 2 hands - not at all like the videos. I couldn't do this in the field.), it causes the sides of the heel plates to flex upwards a bit. It also raises the toe half of the board so there is a small split-level on the base. Is this normal? It seems like the toe plate is too short and needs to be shimmed higher off the board by quite a bit, but that wouldn't fix the heel problem. The tension has scratched the top of the pins - I hope I didn't damage anything.

2) The tabs on the plates that overhang onto the other half of the board are too long to use the bindings anywhere from -5 to +10 degrees. I used a file to grind it down a bit and eventually got it to fit at 0 degrees. It is possible this is an issue with the board binding spacing being a bit off. I'll consider this solved, but it sure was frustrating.

3) My tall heel riser bars weren't bent correctly. At first I didn't notice any problem and put them together and mounted them on my board. Then I noticed they were very stiff. I pulled one up and it damaged the plastic base by rounding off the corners that hold the wire in the up position. My short riser bars worked as I expected, without too much effort. I had to bend the taller bars to be nearly 1/4in wider at the base before they would function as they do in the videos. Good news is the rounded corners don't seem to affect functionality. Still, if they're not going to be precisely sized there should at least be something in the instructions saying they may need to be bent and adjusted.

4) My ride mode clamps are very very difficult to get undone. I doubt I could get them undone while touring, especially not with gloves. They aren't this tight is any of the videos I've seen. I can deadlift 400lbs and can climb 5.9, so strength shouldn't be an issue. Do they loosen up over time? Or are mine just 'off'?


For $600 you'd think these sort of things wouldn't be an issue - I'm really disappointed so far :banghead: . Does anyone have insights to help me out?


Top
 Profile  
 
 Post subject: Re: Trouble with Split30s - Nothing seems to fit
PostPosted: Wed Feb 19, 2014 8:45 pm 
Offline
User avatar

Joined: Thu Feb 17, 2011 2:12 pm
Posts: 144
I have split 30's on a Venture Storm. I have none of the problems you describe. There is a bit of a technique to set them up right. Did you contact Karakoram? They are very helpful and responsive.

_________________
It is obvious that we can no more explain a passion to a person who has never experienced it than we can explain light to the blind. T.S.Eliot


Top
 Profile  
 
 Post subject: Re: Trouble with Split30s - Nothing seems to fit
PostPosted: Mon Feb 24, 2014 11:34 am 
Offline

Joined: Thu Sep 17, 2009 2:38 pm
Posts: 320
Location: Fairhaven
COadv-
Did you get things sorted out? There are some good tutorial videos and the brothers are very good about replying to emails and will get back to you if you need help from them. Good luck!

_________________
I only ski uphill, mostly.


Top
 Profile  
 
 Post subject: Re: Trouble with Split30s - Nothing seems to fit
PostPosted: Thu Feb 27, 2014 2:59 pm 
Offline

Joined: Mon Jan 13, 2014 12:57 pm
Posts: 3
I've gone through all the videos and none of them address the problems I'm having. I sent the brothers an email, so hopefully they'll have some input.


Top
 Profile  
 
 Post subject: Re: Trouble with Split30s - Nothing seems to fit
PostPosted: Fri Feb 28, 2014 9:58 am 
Offline

Joined: Thu Sep 17, 2009 2:38 pm
Posts: 320
Location: Fairhaven
Where are you located? Maybe someone local with Karakoram experience can help you out.

_________________
I only ski uphill, mostly.


Top
 Profile  
 
 Post subject: Re: Trouble with Split30s - Nothing seems to fit
PostPosted: Tue Mar 04, 2014 2:51 pm 
Offline

Joined: Mon Oct 15, 2012 6:43 am
Posts: 16
Russ at Karakoram was v helpful when I had some problems with fitting the bindings - defo drop him a line, and send him photos so he can see the problem.


Top
 Profile  
 
 Post subject: Re: Trouble with Split30s - Nothing seems to fit
PostPosted: Fri Mar 07, 2014 9:09 am 
Offline
User avatar

Joined: Mon Mar 05, 2012 9:20 am
Posts: 293
Location: a mile high COLORADO
If your local and still need help Im rocking some K bindings and have them pretty dialed. I have mounted them on a couple different setups without issue. I' dbe glad to help.

_________________
There's snow somewhere.


Top
 Profile  
 
 Post subject: Re: Trouble with Split30s - Nothing seems to fit
PostPosted: Fri Mar 07, 2014 6:11 pm 
Offline

Joined: Mon Jan 13, 2014 12:57 pm
Posts: 3
Thanks for the suggestions!

I finally got to talk to Russell this afternoon (We've both been really busy and trouble finding time we were both free). He was very helpful and gave me several suggestions to try for each of my issues. I'll work on my setup more this weekend and give you an update.

@cometogether I'm also in Denver. If I'm still having issues after this weekend I would love to meet up. Thanks for the offer!


Top
 Profile  
 
 Post subject: Re: Trouble with Split30s - Nothing seems to fit
PostPosted: Fri Mar 28, 2014 9:54 am 
Offline

Joined: Wed Nov 16, 2011 11:11 am
Posts: 37
I've been using mine for 2 years and haven't had any issues. I agree with the setup being precise. I bought mine used and the tabs over hanging the board edges were filed so I assume that gent had the same problem but for my setup they aren't even close to being a problem.

As far as their function: I woudln't lend the board to someone and expect the transition to go perfect. I would show them how they operate so they can understand how and how-not to put them together.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  





Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group