Splitboard.com Forums

The World's first exclusive splitboard discussion forums






It is currently Wed Apr 16, 2014 3:38 am

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: spark tail clip install issue
PostPosted: Sat Dec 22, 2012 9:49 pm 
Offline

Joined: Thu Jan 25, 2007 10:00 pm
Posts: 48
Location: Seattle
evening folks---- anyone have issues trying to install the spark tail clips on voile skins? the rivets keep popping off when i pull the stretchy to put the clip on the tail....more force when i hammer the rivet?

thanks,
mc

_________________
orography is our pornography


Top
 Profile  
 
 Post subject: Re: spark tail clip install issue
PostPosted: Sat Dec 22, 2012 10:01 pm 
Offline
User avatar

Joined: Sat Mar 19, 2011 6:48 pm
Posts: 642
Location: Kodiak, AK
I was not impressed with the rivets Spark included in their kit. Actually they pretty much sucked. One one set I sucked it up and smashed the rivets until they held. A straight drive with the hammer so that the two halves seat together helps. If they go all diagonal to each other you are screwed. On another set of skins I sewed the straps on. Both have worked fine.

_________________
Jones Solution 163W
Venture Zephyr 164/260
Never Summer SL 163X
Burton Spliff 148
Voile Mojo RX 166
BD, G3, and Gecko skins
Sparks!


Top
 Profile  
 
 Post subject: Re: spark tail clip install issue
PostPosted: Sun Dec 23, 2012 12:33 pm 
Offline
User avatar

Joined: Tue Jan 29, 2008 12:37 pm
Posts: 139
Location: East of the Cascades, Wa
I've installed about 8 sets of these for friends and customers and have never had any issues with the rivets. My personal skins are on season 3 with the tail clips. If thy pop off you just need to wack em with a hammer a couple more times and you will be set.

_________________
http://www.chair2boardsports.com/-Washingtons First Backcountry Snowboards Shop


Top
 Profile  
 
 Post subject: Re: spark tail clip install issue
PostPosted: Sun Dec 23, 2012 1:32 pm 
Offline

Joined: Wed Mar 23, 2005 8:51 am
Posts: 635
B-P wrote:
I've installed about 8 sets of these for friends and customers and have never had any issues with the rivets. My personal skins are on season 3 with the tail clips. If thy pop off you just need to wack em with a hammer a couple more times and you will be set.



Same experience here. Make sure you have 'em on a flat, hard surface and hit them directly with the hammer. Never had a problem.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron








Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group