Forums Splitboard Talk Forum "Whale" tip clip no longer seems to fit
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #815061
    Nesha
    5 Posts

    Hi,

    The tip clip (whale shape) at the nose of my board doesn’t seem to line up anymore, its like the board isn’t fitting together as tight as it used to. I don’t think I am doing anything differently and the rest of the board seems to line up, any suggestions or ideas what the cause could be?

    Cheers,

    Nesha

    #815087
    Scooby2
    608 Posts

    Two possibilities are: that one of the rivets has widened its hole toward the other, or the clip has deformed or stretched out a bit.

    #815121
    Matt Wood
    328 Posts

    Is it the clip itself or is it the tips (skis) that are not lined up? Have you recently adjusted your stance? Do you use Karakorum interface?

    #815154
    Scooby2
    608 Posts

    IMO tip clips do two main things, they keep brush from wedging in and they help hold your split together before touring brackets go on. If it stays put when closed, don’t sweat it. If the clip forces itself apart you can file (or sand with sandpaper and a round thing) out the side of the round near the center line of the board so it doesn’t want to pop off.
    If it is super loose and you do not want to hassle with replacing it, you can build up layers of tape under the whale tail to make it thicker so it stays stuck under the rivet head and cut or sand a tiny bevel so it still slides under the rivet head easy.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.